Перейти к содержанию

Все компьютеры предприятия на Linux перестали выходить в интернет


Рекомендуемые сообщения

Добрый вечер!

 

Сегодня утром случилось ужасное  :zloy:

 

Все компьютеры в конторе работающие под операционной системой Linux дружно отказались соединяться с интернетом. В то же время те компьютеры, которые работают под операционной системой Windows, никаких проблем не испытывали.

 

Настройки сетевого подключения одинаковые как на Windows, так и на Linux — прописан статический IP-адрес, в качестве DNS-серверов указаны гугловские 8.8.8.8 и 8.8.4.4

 

Ситуация конечно-же довольно странная. Компы под Линуксом работают уже почти 3 с лишним года и такое случилось в первый раз.

 

Взял проблемный комп и подключил его к другому модему — результат нулевой, интернета нет.

 

Подключил этот компьютер к симметричному каналу по SHDSL, результата также нет. Позвонил в другую контору по нашему-же профилю в областной центр, коллега сообщил, что никаких проблем на Линуксе у них нет. Но вчера у них несколько раз отключали подачу электроэнергии и после этого были какие-то похожие проблемы у местного провайдера с потерей доступа к интернет, посоветовал проверить настройку DNS.

 

Позвонил в техподдержку провайдера, те как всегда стали уверять, что с интернетом нет проблем, мол «одни вы такие, проблема у вас».

 

Попробовал сменить DNS — результата нет, интернет не работает.  Удалил сетевое подключение, создал его заново с другим DNS-сервером, который рекомендует провайдер и тут всё заработало! Ух ты!

 

А теперь собственно вопросы:

 

1)  Что это такое было?

2) Почему компьютеры из под Windows, в  отличие от линуксовых машин, не испытывали никаких проблем с подключением?

3) Как таких проблем избежать в дальнейшем?

 

 

 

Ссылка на сообщение
Поделиться на другие сайты

@Sandynist

Если линукс тачки одинаковые, и виндовые тачки как часы работали тут 3 вещи приходят в голову:

1) прикатила какая-то обнова (если настроено)

2) Специфичный червяк прошелся, что мало вероятно.

3) какая-то фантомная хрень, которую не возможно объяснить, но после не очевидных плясок всё начинает работать, что произошло в вашем случае ;)

Ссылка на сообщение
Поделиться на другие сайты

создал его заново с другим DNS-сервером

каким именно?

*а если этот днс прописать у всех, то не начинает работать?

Изменено пользователем oit
Ссылка на сообщение
Поделиться на другие сайты

 

 


интернета нет.

Когда это всё дело происходит, нужно начинать с пингов шлюзов (своего, провайдера) пинга IPадресов DNS серверов. так быстрее проблемная область сузится .

 

Вроде бы Можно так же в линуксах с помощью утилиты dig посмотреть, отвечают ли DNS сервера на ваши запросы.

могу ошибаться но вроде так это выглядит :

dig @8.8.8.8 ya.ru

Где после собаки адрес тестируемого DNS 

  • Спасибо (+1) 1
Ссылка на сообщение
Поделиться на другие сайты

 

 


1) прикатила какая-то обнова (если настроено)

 

Нет, обновления на Линуксе ставятся в ручном режиме и только после ввода пароля. Этот вариант сразу же отпадает.

 

 

 


Вроде бы Можно так же в линуксах с помощью утилиты dig посмотреть

 

Спасибо, надо будет попробовать.


Не очень ясно почему-же доступ пропал.

 

Перезагрузка компьютера не помогла. На момент перезагрузки все гугловские DNS-серверы отлично пинговались. Или то, что они пингуются ещё не факт, что отрабатывают имена? Подключение к другой точке раздающей интернет тоже не помогло.

 

Только удалением соединения и созданием нового подключения  решилась проблема.


Ещё вот вчерашние новости, это уже про:

 

 

 


какая-то фантомная хрень, которую не возможно объяснить

 

Авторы уверяют, что это была очень искусно обставленная атака на Транстелеком.


Ещё по той-же теме: https://tjournal.ru/67668-v-prichine-masshtabnogo-sboya-provaydera-ttk-zapodozrili-uyazvimost-v-reestre-roskomnadzora

Ссылка на сообщение
Поделиться на другие сайты

@Sandynist, это не может объяснять то, что ты на своем ПК меняешь сетевое подключение и после перезагрузки у тебя начинает работать с теми же самыми настройками.

Ссылка на сообщение
Поделиться на другие сайты

Удалил сетевое подключение, создал его заново с другим DNS-сервером, который рекомендует провайдер и тут всё заработало!

Настройки были не те же самые. В результате атаки (как пишут по приведённым выше ссылкам) полегли серверы Транстелекома, через которые мы получаем ответы на DNS-запросы от серверов Гугла.

Изменено пользователем Sandynist
  • Согласен 1
Ссылка на сообщение
Поделиться на другие сайты

Настройки сетевого подключения одинаковые как на Windows, так и на Linux — прописан статический IP-адрес, в качестве DNS-серверов указаны гугловские 8.8.8.8 и 8.8.4.4

...

3) Как таких проблем избежать в дальнейшем?

Интересно, никого этот момент не смутил? Вручную прописываются компьютерам IP адреса, вместо технологии DHCP...

От этого и проблемы.

 

Ссылка на сообщение
Поделиться на другие сайты

Специально для тех, кто использует только автоматические настройки, поясняю:

 

1) DHCP конкретно у нас отключено потому, что в связи с недостаточно корректным разделением каналов в ADSL-модеме, предоставляемом провайдером для услуг интернет, при включённом DHCP происходит захват IP-адреса SIP-шлюзом из локальной сети, а не от SIP-сервера провайдера.

 

2) Каким образом учитывать расходуемый пользователями трафик интернет при динамической IP-адресации? Если у вас есть готовое решение, то я вас внимательно выслушаю  :zloy: И только при условии, что вы поможете победить баг под №1.

 

Примечание:  Вы уже не в первый раз со своими деструктивными замечаниями отмечаетесь в моих темах, никакой особой пользы не приносите своими советами, но вызываете кучу дополнительного никому ненужного флейма.

 

Ваша цель вот в данном конкретном случае какая?

 

Попытаться балл заработать не разбираясь в сути вопроса или вызвать у меня какую-то ответную реакцию?

Изменено пользователем Sandynist
Ссылка на сообщение
Поделиться на другие сайты

Сегодня несколько компьютеров под виндой точно также перестали выходить в интернет. Только перепрописывание в сетевых настройках местных DNS-серверов и помогает. Наверное это такое ЦУ.

 

 

Тему закрываю, так как ясно, что Линукс тут уже не при чём.

Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.
  • Похожий контент

    • От serznamens
      Имею Linux Ubuntu 20.04, сделал фулл дамп, просканировал программой Volatility.
       
      Гворят легко заблокировать по адресу.
       
      Вот список левых процессов:
       
      Судя по названию первого процесса - "0?{??U" (ты ноль) , на пульте школьник.
       
      Offset
         | Name | Pid 0x0000000008016700    | 0?{??U | 5253 0x0000000049f75700    | | 5659 0x0000000069e6dd40    | | 745 0x000000006f1ec700    | | 5683 0x000000007a87fb40    | | 5683 0x00000000884ea700    |  )?Hc???Hi??Mb?? | 2477 0x000000009745f700    | | 2934
    • От AlexKr1975
      Добрый день.
       
      Никто не сталкивался с проблемой? 
      Ubuntu 18.04, после установки KES for Linux 10.1.1.6421, kdump не формирует дампы. При ручном крэштесте система или зависает или ребутается, но дампы не создаются. После удаления KESL всё работает.
       
      Заранее спасибо.
    • От Alexander 69
      есть медиахранилище куда имеют доступ по локальной сети 10 человек
      все зашифровалось
      сканирование аппаратов которые имели доступ ничего не нашло
      на самом медиа хранилище сканирование запустить не удалось потому как оно пока не запускается - переполнилось по какойто причине (пытаюсь почистить и запустить)
      есть только копии файлов которые я успел скачать пока оно было доступно
       
      Farbar Recovery Scan Tool запускал только на той машинке на которой лежат копии зашифрованных файлов но все равно прилагаю
       
      архив с файлами прикрепляю пароль как сказано в инструкции
      *архивы на носителе остались целыми
       
      virus.rar Addition.txt FRST.txt FRST.txt
    • От Mekka2g
      Есть 10 KES. Есть графическая оболочка Cinnamon. За графику отвечает графический чипсет AMD. При конфигурации GUI касперский в системном трее:
      1) отображается не в виде значка, а в виде красного прямоугольника
      2) При ПКМ на системном значке Контекстное меню отображается некорректно, оно увеличивается в разы (то есть масштабирование этого меню не работает)
      3) Если два раза нажать на значок в трее ( или запустить GUI из меню) GUI не отображается (черный экран).
      Проблемы именно в Cinnamon. На том же дистрибутиве в MATE всё отлично.
      Причем не на всех мониторах эта проблема прослеживается.
      На графических чипсетах от Intel проблем замечено не было.
    • От Константин Стрельников
      Пытаюсь прикрутить ks8 к zimbra, затупил над конфигом postfix. В зимбре он немного развесистый и я не понимаю что надо закомментировать и куда вписывать своё. И тут ещё момент что у нас ks8 установлен на отдельной виртуалке, это тоже надо сконфигурировать. master.cf приложил, если кто может направить в какую секцию что запузыривать и что закомментировать буду очень благодарен. Интегрировать думал по варианту BEFORE - QUEUE
      master.zip
×
×
  • Создать...